Compartir
Publicidad

Las 17 fórmulas de Excel esenciales para empezar y aprender fórmulas de Excel

Las 17 fórmulas de Excel esenciales para empezar y aprender fórmulas de Excel
29 Comentarios
Publicidad
Publicidad

Excel es, con permiso de Google Sheets, la aplicación hoja de cálculo por excelencia, valga la redundancia. Con Excel puedes hacer de todo, si sabes usar las fórmulas apropiadas. Hoy veremos 17+ fórmulas de Excel esenciales que te ayudarán a crear hojas de cálculo más inteligentes.

Las fórmulas de Excel son el corazón del programa, pues son las que se encargan de hacer el "cálculo" de la hoja de cálculo. Hoy revisaremos las fórmulas más útiles para el público general, con ejemplos de cómo usar cada una.

Operaciones matemáticas simples

Suma

Antes de entrar en fórmulas más complicadas, veamos cómo hacer las operaciones matemáticas más simples: sumas, restas, multiplicaciones y divisiones. Técnicamente solo la suma es una fórmula, pues en el resto de los casos se usan operadores especiales.

  • SUMA: esta fórmula suma los valores de las celdas en su interior. Soporta tanto celdas separadas como intervalos. Ejemplo: =SUMA(A1:A50)

  • Restas: para restar los valores de dos celdas debes usar el símbolo de resta "-" entre ambas. Ejemplo: = A2 - A3

  • Multiplicaciones: para multiplicar los valores de dos celdas debes intercalar entre ellas un asterisco *. Ejemplo: = A1 * A3 * A5 * A8

  • Divisiones: para dividir los valores de dos celdas debes incluir entre ellas la raya /. Ejemplo: = A2 / C2

Excel respeta el orden lógico de las operaciones matemáticas (multiplicaciones y divisiones primero, luego sumas y restas) y suporta el uso de paréntesis para dar prioridad a unas operaciones sobre otras. De este modo, puedes crear fórmulas como = (A1 + C2) * C7 / 10 + (D2 - D1).

PROMEDIO

Promedio

La fórmula promedio devuelve el valor de promedio aritmético de las celdas que pases o rango de celdas que pases como parámetro. Este resultado también es conocido como media o media aritmética.

  • Uso: =PROMEDIO (celdas con números)

  • Ejemplo: =PROMEDIO (A2:B2)

MAX y MIN

Maxmin

Si en lugar de querer saber la media aritmética deseas conocer cuál es el mayor valor o el menor valor de un conjunto, tienes a tu disposición dos fórmulas de nombres previsibles: MAX y MIN. Las puedes usar con celdas separadas o rangos de celdas.

  • Uso: =MAX(celdas) / =MIN(celdas)
  • Ejemplo: =MAX(A2:C8) / =MIN(A2,B4,C3,29)

SI.ERROR

Sierror

SI.ERROR es una fórmula que te sacará de más de un apuro. Con ella puedes evitar los errores #¡DIV/0! y similares. Esta fórmula te permite devolver un valor en el caso de que otra operación resulte un error. Esto es bastante común con divisiones, pues cualquier división entre cero dará error, pudiendo provocar una reacción en cadena de errores. La operación en cuestión puede ser una operación o cualquier otra fórmula.

  • Uso: =SI.ERROR( operación, valor si hay un error)
  • Ejemplo: =SI.ERROR (MAX(A2:A3) / MIN(C3:F9),"Ha habido un error")

SI

Si

SI es una de las fórmulas más potentes de EXCEL y es que con ella puedes devolver un resultado distinto según si se cumple la condición. De este modo, podrías usarlo para que una celda diga "APROBADO" si otra es un número superior a 5, o "SUSPENDIDO" si es inferior.

  • Uso: =SI(condición, valor si se cumple la condicion, valor si no se cumple)
  • Ejemplo: =SI(B2="Madrid","España","Otro país")

CONTARA

Contara

CONTARA es una de las fórmulas para contar valores. A diferencia del simple CONTAR, CONTARA cuenta también valores que no sean números. Lo único que ignora son las celdas vacías, de modo que te puede ser útil para saber cuántas entradas tiene una tabla, independientemente de si los datos son numéricos o no.

  • Uso: =CONTARA(rango de celdas)

  • Ejemplo: =CONTARA(A:A)

CONTAR.SI

Contarsi

La fórmula CONTAR.SI es una especie de mezcla de las dos anteriores. Contará el rango de celdas especificado siempre y cuando cumplan ciertos requisitos. Estos puede ser que tengan cierto valor o que cumplan ciertas condiciones.

  • Uso: =CONTAR.SI(rango de celdas, criterio)
  • Ejemplo: =CONTAR.SI(C2:C, "Pepe")

ALEATORIO.ENTRE

Aleatorioentre

Esta fórmula genera un número aleatorio entre otros dos números dados, y por tanto resulta ideal cuando necesitas elegir algo al azar. El número generado cambia cada vez que se regenera la hoja (por ejemplo, cuando escribes un nuevo valor).

  • Uso: =ALEATORIO.ENTRE( numero menor, numero mayor)

  • Ejemplo: =ALEATORIO.ENTRE (1,10)

DIAS

Dias

Los cálculos de fechas son siempre un tema peliagudo si los debes hacer a mano, pero todo es mucho más fácil cuando una fórmula hace el trabajo duro por ti. DIAS te dice el número de días que hay de diferencia entre dos fechas.

  • Uso: =DIAS( primera fecha, segunda fecha)

  • Ejemplo: =DIAS ("2/2/2018", B2)

AHORA

Ahora

Otro esencial de Excel es la fórmula AHORA. Esta genera la fecha para el momento actual y es un dato que se actualizará automáticamente cada vez que abres la hoja o sus valores se recalculan (porque cambias una celda, por ejemplo). Esta fórmula no requiere de ningún parámetro.

  • Uso: =AHORA()

  • Ejemplo: =AHORA()

DIASEM

Diasem

DIASEM es otra útil fórmula relacionada con fechas, que devuelve de forma numérica el día de la semana de una fecha. El lunes es el 1, el martes es el 2, y así sucesivamente, aunque hay varias formas de empezar a contar, como puedes indicar en el segundo parámetro.

  • Uso: =DIASEM (fecha, tipo de cuenta)

Para tipo de cuenta, debes usar uno de estos parámetros:

  • 1: números del 1 (domingo) al 7 (sábado)

  • 2: números del 1 (lunes) al 7 (domingo)

  • 3: números del 0 (lunes) al 6 (domingo)

  • 11: números del 1 (lunes) al 7 (domingo)

  • 12: números del 1 (martes) al 7 (lunes)

  • 13: números del 1 (miércoles) al 7 (martes)

  • 14: números del 1 (jueves) al 7 (miércoles)

  • 15: números del 1 (viernes) al 7 (jueves)

  • 16: números del 1 (sábado) al 7 (viernes)

  • 17: números del 1 (domingo) al 7 (sábado)

  • Ejemplo: =DIASEM (AHORA(), 2)

HIPERVINCULO

Hipervinculo

Excel convierte automáticamente las direcciones web en enlaces, pero si quieres crear un enlace con un texto distinto, necesitas usar una formula. Esa fórmula es HIPERVINCULO, con la cual puedes añadir enlaces a cualquier celda.

  • Uso: =HIPERVINCULO ( dirección del enlace, texto del enlace )

  • Ejemplo: =HIPERVINCULO ( "http://www.google.com", "Visita Google")

TRANSPONER

Transponer

TRANSPONER cambia las filas por columnas y es una fórmula un poco especial. Debes aplicarla a una selección de filas que coincida de forma inversa con la tabla que quieres trasponer. Por ejemplo, si la tabla original tiene 2 filas y 4 columnas, necesitas aplicarla a 4 filas y 2 columnas. Además, es una fórmula de matriz, así que necesitas pulsar Control + Mayúsculas + Intro para aplicarla.

  • Uso: {=TRANSPONER { intervalo de celdas )}

  • Ejemplo: {=TRANSPONER ( A1:C20)}

REEMPLAZAR

Reemplazar

REEMPLAZAR es una útil fórmula con la cual puedes insertar o reemplazar parte de un texto. No consiste en reemplazar un texto por otro (esa es la fórmula SUSTITUIR), sino en insertar un texto en determinada posición y, opcionalmente, sustituyendo parte del texto original. Con sus dos parámetros eliges en qué posición se inserta el texto, así como a cuántos caracteres se eliminarán del texto original, después de esa posición

  • Uso: =REEMPLAZAR ( texto original, ubicación donde se inserta, caracteres del texto original que se borran, texto a insertar )

  • Ejemplo: =REEMPLAZAR ( "Feliz Navidad", 6, 8, " Hanukkah")

CONCATENAR

Concatenar

CONCATENAR es una fórmula que te puede sacar de varios apuros. Su utilidad es tan simple como juntar varios elementos de texto en un único texto. Como parámetro no puedes especificar un rango de celdas, sino celdas individuales separadas por comas.

  • Uso: =CONCATENAR( celda1, celda2, celda3 ... )

  • Ejemplo: =CONCATENAR ( A1, A2, A5, B9)

ESPACIOS

Espacios

Los espacios de más en un texto pueden ser problemáticos pues no siempre los podrás detectar a simple vista. Una forma de acabar con ellos fácilmente es con ESPACIOS, que elimina todos los espacios de más de un texto, independientemente de dónde se encuentren.

  • Uso: =ESPACIOS ( celda o texto con espacios de más )

  • Ejemplo: =ESPACIOS ( F3 )

ENCONTRAR

Encontrar

ENCONTRAR es una fórmula con la cual puedes saber si el texto de una celda contiene otro texto. En caso afirmativo, la fórmula devuelve la posición en el texto donde se encontró la primera concurrencia. Si no, devuelve un error (acúerdate de usar SI.ERROR para controlar estos casos).

  • Uso: =ENCONTRAR(texto que estás buscando, texto original)

  • Ejemplo: =ENCONTRAR ( "aguja", "pajar" )

En Xataka Basics | Cómo crear una lista desplegable en Excel

Temas
Publicidad
Publicidad
Publicidad
Inicio
Inicio

Ver más artículos